Altis Flight Manager
PC application for AerobTec devices

AerobTec Altis v3 User Manual

1

Table of Contents
Introduction.........................................................................................................................3
Requirements..................................................................................................................3
Installation...........................................................................................................................3
Application.......................................................................................................................3
USB Driver for Altis v3 interface ALink...........................................................................4
.NET Framework.............................................................................................................4
User interface.....................................................................................................................5
Main window...................................................................................................................5
Obtaining data.................................................................................................................5
Flight list..........................................................................................................................5
About the flight................................................................................................................6
Flight description tab.......................................................................................................6
Graph tab........................................................................................................................7
Vario filter........................................................................................................................9
Flights Comparer.....................................................................................................9
Further work with data..................................................................................................10
Program settings...........................................................................................................11
Altis v3 window..............................................................................................................11
Revision History................................................................................................................12

AerobTec Altis v3 User Manual

2

1.Introduction
The AerobTec Altis Flight manager is a PC application which serves to communicate with the AerobTec
Altis devices and to display and process the flight data recorded by it.

Requirements
•Windows XP or higher
•256MB RAM or more
•min 20MB of free disk space
•free USB port
•.NET Framework 3.5 or higher
•1GHz Pentium III or Athlon, or better
•1024x768 pixels screen resolution

2.Installation
Application
The latest version of the AerobTec Altis Flight manager installation program is available on our website on
the following link:
http://www.aerobtec.com/products/rc-electronics/altis-flight-manager/#tab-3
Before you start installation of the program, please make sure that an older version of the application is
correctly uninstalled. For AerobTec Altis Flight Manager installation execute installation program and follow
the installation instructions on the screen.

USB Driver for Altis v3 interface ALink
In case you are using Altis Flight manager with Altis v3 device the provided USB adapter ALink serves as
a virtual serial port and requires a USB driver. An installation program for USB driver for Windows (XP or
higher) is available on the following web link:
http://www.aerobtec.com/download/CDM20814_Setup.zip
For proper installation on your PC please execute this program and follow the installation instructions on
the screen.

.NET Framework
The AerobTec Altis Flight manager application also requires .NET Framework 3.5 or higher to be installed
on the computer. It can be installed from the following link:
http://www.microsoft.com/en-us/download/details.aspx?id=21
Please follow the installation instructions on the screen.
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3.User interface
Main window
The main window contains several parts. There are these main sections: main menu, toolbar, flight list,
graph tab, flight description tab, start page tab, flight properties frame.
The following part of the manual explains how to use the program.

Fig. 2. AerobTec Altis Flight manager PC application main window

Obtaining data
Altis Flight manager is used to work with data from AerobTec devices.
There are several ways how to get the data:
Open file – you can load a file that was saved by Altis Flight manager before. This options is available in
File->Open
Altis v3 – You can download the data from Altis v3. For this, connect the USB adapter to PC, connect Altis
v3 to the adapter and run Tools->Device and choose Altis v3. Press Read data button on the Altis v3
window. After the data is downloaded, you can close the window and start to work with it.
Altis v4 - You can download the data from Altis v4. Connect Altis v3 to PC and run Tools->Device and
choose Altis v4. Press Download data button on the Altis v4 window. After the data is downloaded, you
can close the window and start to work with it. Note that all (also historical) downloaded data from your is
available in the application data folder. The exact location in your filesystem depends on your operating
system.

Flight list
Once you loaded the data you can start examine the individual flights. There is a flight list on the left side
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of the screen. User can use this to selet the downloaded flights, rename or remove them. This list allows
you to change flight and marker name and removed selected item from the list.

Fig. 3. Flight list

About the flight
Each flight can be characterized by some statistical information. Information such as
•

Flight length in seconds

•

Sample time in seconds

•

Max and min altitude in selected altitude units

•

Max and min calculated vertical speed in selected altitude units

•

F5J start altitude for current flight

are available in Fligth properties (bottom left part of the window).

Fig. 4. Flight properties frame

Flight description tab
Flight description tab serves to insert comments to the selected flight or marker, set pilot name, airport
name and time when and where the flight was recorded.
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Fig. 5. Flight description tab

Graph tab
The most important feature of the Altis Flight manager is the possibility to view the flights in a graphical
form.
The chosen flight is displayed in the Graph tab (Fig. 6). The graph displays how the parameters changed
over time. Several measured parameters can be showed in this graph by selecting them from Graph menu
or also from graph tab itself. Each variable has its own ax and color.
The following parameters can be displayed on the graph:
o

Altitude - altitude measured by Altis device

o

Vario - vertical speed calculated from altitude data

o

Voltage - Altis device supply voltage

o

Temperature - temperature measured by Altis device

o

Throttle In - throttle in channel level measured by Altis device

o

Throttle Out - throttle out generated by Altis device (only on Altis v4 model)

o

Markers - markers for specific event occurred during flight

The graph can be zoomed in and out or set to basic scale by buttons in toolbar or tool menu.
When the Zoom in function is on, user can also use the middle mouse button for advanced graph zooming
and moving. When the middle button is pressed and user moves the mouse, the graph moves while the
mouse wheel zooms in and out.
The program also offers a graph measuring function available in the Tools menu or in the toolbar. When
the function is activated, user clicks on the graph at the chosen time and moves the cursor. There is a
triangle connecting the graph point at the start time and a graph point at the cursor time. Time difference,
altitude difference and average climbing are shown on the graph. This is shown in Fig. 7.
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Fig. 6 Graph tab
When a flight is recorded, there may be some parts in the beginning and in the end of the flight which are
not interesting for the user or user wants to split the flight into two or more flights. User can discard these
parts by using Trim Graph Start tool and Trim Graph End tool and split flight using Split Graph tool
available in the toolbar and Tools menu.

Fig 7. Measuring function
Each flight recording begins in the reference altitude, which is always 0m. However, user might know the
altitude the aircraft starts in. This altitude can be set in the graph by the Set Zero Altitude tool, which is
also available in Tools menu and the toolbar.
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Vario filter
Since the vario data is very noisy, there is a filtering feature available in Graph → Vario Settings... Filter
value can be selected manually. The filtered graph is shown online. The difference of the same flight with
a different filter values is shown in Fig. 9.

Fig. 8. Comparison of vario signal filtered with different filter settings
How to use vario filter
Set the graph to show altitude and vario. Choose an area where you can measure the climbing rate
preciselly enogh. Read the value. In our case, the average climbing rate in the selected area is 7,85m/s.
Use vario filter to set approximately 7,5m/s vario values in the same area.

Fig. 9 Setting the appropriate vario filter value.

Flights Comparer
Sometimes user might wish to compare several different flights. It is possible via Flight Comparer function
available in Tools → Flights Comparer.... User opens the file with saved flights and checks the checkboxes
of the files to be compared. An example of such a comparison is shown in Fig. 10. The graph can be
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zoomed in and out and moved using the middle mouse button. The displayed graph can be exported to an
image or printed.

Fig. 10. Flight comparer

Further work with data
Altis Flight manager offers several ways of data export, so you can use the displayed graph in your
prefered way.
Save file – Altis Flight manager saves the data in its native format (.afr). It is available in File->Save
Export data: available in File->Export
•

HTML – stores the graph as a html web page

•

Image – exports the image to file. Various formats (png, jpg, gif, tif, png) are supported.

•

CSV file – export in Coma separated value for further processing in Microsoft Excel, Open office
Calc or other spreadsheet processors.

•

Vector image – exports the image in a vector file svg

Facebook -sends the graph directly to your facebook account. Internet connection and facebook account
details must be provided.
This function is available by a facebook button in the bottom right corner of the Graph tab. (Fig. 6)
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Program settings
Basic settings of the program are available in the Settings window which can be found in File → Program
Settings.... User can choose preferred language, length units (meters, feets and yards) and the
communication port where the Altis v3 device is connected. The button Search Device checks all available
Com ports and recommends user port with active AerobTec Altis v3 device.

Fig. 11. Settings window

Altis v3 window
This window communicates directly with connected AerobTec Altis v3 device. User can choose this
window in Tools → Device or in the toolbar. When opening the window, the device should be connected;
otherwise it will not be opened. During the launch, the settings of the device are loaded and shown in the
window. User can change the sampling time in the range from 0.1 to 25.5s with step of 0.1s. The serial
number of the device as well as firmware version and actual memory usage are also shown here.
There are some settings regarding competition rules. User can select altitude switch function, time switch
function or F5J FAI competition settings. In some competitions it is not allowed to switch the motor on
again during the flight. However, it is desirable to have the possibility to switch the motor on again in an
emergency. User can choose to enable this or not. If enabled, the emergency switch on is recorded and
can be shown on the flight graph.
User has three possibilities to trigger the recording of data. It can be triggered from certain altitude, by RC
signal or the recording can be always on.

Fig.12. Altis v3 window
User can read the settings from Altis v3 device again and write the new settings to it. The recorded flight
data can be read by button Read Data. After reading, the memory of the device can be erased to obtain
more space for new flights. However, user can continue using the free memory for new flights.
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4.Revision History
Rev. 1.0. (July 2013)
•Initial release
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